$re = '/(([^<>()\[\]\\\\.,;:\s+@"]+(\.[^<>()\[\]\\\\.,;:\s@"]+)*)|(".+"))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))/m';
$str = 'mikey.martin@themartins.kiwi
mm15032@students.sacredheart.school.nz
mm15032@students..sacredheart.school.nz
mm15032students.sacredheart.school.nz
@students.sacredheart.school.nz
mm15032@@students.sacredheart.school.nz
mm15032@students.sacredheart.school.nz@
.mm15032@students.sacredheart.school.nz
+mm15032@students.sacredheart.school.nz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);