using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(([^<>()\[\]\\.,;:\s+@""]+(\.[^<>()\[\]\\.,;:\s@""]+)*)|("".+""))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))";
string input = @"mikey.martin@themartins.kiwi
mm15032@students.sacredheart.school.nz
mm15032@students..sacredheart.school.nz
mm15032students.sacredheart.school.nz
@students.sacredheart.school.nz
mm15032@@students.sacredheart.school.nz
mm15032@students.sacredheart.school.nz@
.mm15032@students.sacredheart.school.nz
+mm15032@students.sacredheart.school.nz";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}