import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([^<>()\\[\\]\\\\.,;:\\s+@\"]+(\\.[^<>()\\[\\]\\\\.,;:\\s@\"]+)*)|(\".+\"))@((\\[[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}])|(([a-zA-Z\\-0-9]+\\.)+[a-zA-Z]{2,}))";
final String string = "mikey.martin@themartins.kiwi\n"
+ "mm15032@students.sacredheart.school.nz\n"
+ "mm15032@students..sacredheart.school.nz\n"
+ "mm15032students.sacredheart.school.nz\n"
+ "@students.sacredheart.school.nz\n"
+ "mm15032@@students.sacredheart.school.nz\n"
+ "mm15032@students.sacredheart.school.nz@\n"
+ ".mm15032@students.sacredheart.school.nz\n"
+ "+mm15032@students.sacredheart.school.nz";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}