const regex = /(([^<>()\[\]\\.,;:\s+@"]+(\.[^<>()\[\]\\.,;:\s@"]+)*)|(".+"))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(([^<>()\\[\\]\\\\.,;:\\s+@"]+(\\.[^<>()\\[\\]\\\\.,;:\\s@"]+)*)|(".+"))@((\\[[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}])|(([a-zA-Z\\-0-9]+\\.)+[a-zA-Z]{2,}))', 'mg')
const str = `mikey.martin@themartins.kiwi
mm15032@students.sacredheart.school.nz
mm15032@students..sacredheart.school.nz
mm15032students.sacredheart.school.nz
@students.sacredheart.school.nz
mm15032@@students.sacredheart.school.nz
mm15032@students.sacredheart.school.nz@
.mm15032@students.sacredheart.school.nz
+mm15032@students.sacredheart.school.nz`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}