#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(([^<>()\[\]\\.,;:\s+@"]+(\.[^<>()\[\]\\.,;:\s@"]+)*)|(".+"))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))"
Local $sString = "mikey.martin@themartins.kiwi" & @CRLF & _
"mm15032@students.sacredheart.school.nz" & @CRLF & _
"mm15032@students..sacredheart.school.nz" & @CRLF & _
"mm15032students.sacredheart.school.nz" & @CRLF & _
"@students.sacredheart.school.nz" & @CRLF & _
"mm15032@@students.sacredheart.school.nz" & @CRLF & _
"mm15032@students.sacredheart.school.nz@" & @CRLF & _
".mm15032@students.sacredheart.school.nz" & @CRLF & _
"+mm15032@students.sacredheart.school.nz"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")