// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?uis)[^.,:;!?_@%*"\-\'\(\)\[\]s\0-9a-zA-Z\x{4e00}-\x{9fa5}()?,、;。:“”!]+"#).unwrap();
let string = "清楚中文以外的文字:日文にっぽんご/にほんご 韩文:조선글/朝鮮글 德语:Användarnamn Världens 100 största språk 2010 [阿拉伯语:أَبْجَدِيَّة عَرَبِيَّة,abjadīyah ʻarabīyah)
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}