import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^.,:;!?_@%*\"\\-\\'\\(\\)\\[\\]s\\0-9a-zA-Z\\x{4e00}-\\x{9fa5}()?,、;。:“”!]+";
final String string = "清楚中文以外的文字:日文にっぽんご/にほんご 韩文:조선글/朝鮮글 德语:Användarnamn Världens 100 största språk 2010 [阿拉伯语:أَبْجَدِيَّة عَرَبِيَّة,abjadīyah ʻarabīyah)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}