package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)[^.,:;!?_@%*"\-\'\(\)\[\]s\0-9a-zA-Z\x{4e00}-\x{9fa5}()?,、;。:“”!]+`)
var str = `清楚中文以外的文字:日文にっぽ んご/にほんご 韩文:조선글/朝鮮글 德语:Användarnamn Världens 100 största språk 2010 [阿拉伯语:أَبْجَدِيَّة عَرَبِيَّة,abjadīyah ʻarabīyah)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}