const regex = /[^.,:;!?_@%*"\-\'\(\)\[\]s\0-9a-zA-Z\x{4e00}-\x{9fa5}()?,、;。:“”!]+/uigs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^.,:;!?_@%*"\\-\\\'\\(\\)\\[\\]s\\0-9a-zA-Z\\x{4e00}-\\x{9fa5}()?,、;。:“”!]+', 'uigs')
const str = `清楚中文以外的文字:日文にっぽんご/にほんご 韩文:조선글/朝鮮글 德语:Användarnamn Världens 100 största språk 2010 [阿拉伯语:أَبْجَدِيَّة عَرَبِيَّة,abjadīyah ʻarabīyah)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}