use strict;
my $str = '清楚中文以外的文字:日文にっぽんご/にほんご 韩文:조선글/朝鮮글 德语:Användarnamn Världens 100 största språk 2010 [阿拉伯语:أَبْجَدِيَّة عَرَبِيَّة,abjadīyah ʻarabīyah)
';
my $regex = qr/[^.,:;!?_@%*"\-\'\(\)\[\]s\0-9a-zA-Z\x{4e00}-\x{9fa5}()?,、;。:“”!]+/uisp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}