re = /(\/\w+)((\s)([a-z0-9\._\-+%]+))?(\s[a-z0-9\._\-+%]+)?/i
str = '/cmd
/cMd
/cmd param
/cmd param1 param2
/cmd start-system_1.0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end