package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(\/\w+)((\s)([a-z0-9\._\-+%]+))?(\s[a-z0-9\._\-+%]+)?`)
var str = `/cmd
/cMd
/cmd param
/cmd param1 param2
/cmd start-system_1.0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}