import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/\\w+)((\\s)([a-z0-9\\._\\-+%]+))?(\\s[a-z0-9\\._\\-+%]+)?";
final String string = "/cmd\n"
+ "/cMd\n"
+ "/cmd param\n"
+ "/cmd param1 param2\n"
+ "/cmd start-system_1.0";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}