using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\/\w+)((\s)([a-z0-9\._\-+%]+))?(\s[a-z0-9\._\-+%]+)?";
string input = @"/cmd
/cMd
/cmd param
/cmd param1 param2
/cmd start-system_1.0";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}