$re = '/(\/\w+)((\s)([a-z0-9\._\-+%]+))?(\s[a-z0-9\._\-+%]+)?/i';
$str = '/cmd
/cMd
/cmd param
/cmd param1 param2
/cmd start-system_1.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);