// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)P(ost)?[\.\s]*(O|0)(ff(ice)?)?[\.\s]+B(o|0)x").unwrap();
let string = "PO Box
P.O. Box
PO. Box
po box
P.o box
PoBox
p.o. Box
post office box 716
Post O. box
Post off box
p office box
p off BOX
p0 box
p0ffice box k";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}