# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"P(ost)?[\.\s]*(O|0)(ff(ice)?)?[\.\s]+B(o|0)x"
test_str = ("PO Box\n"
"P.O. Box\n"
"PO. Box\n"
"po box\n"
"P.o box\n"
"PoBox\n"
"p.o. Box\n"
"post office box 716\n"
"Post O. box \n"
"Post off box\n"
"p office box\n"
"p off BOX\n\n"
"p0 box\n"
"p0ffice box k")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.