#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)P(ost)?[\.\s]*(O|0)(ff(ice)?)?[\.\s]+B(o|0)x"
Local $sString = "PO Box" & @CRLF & _
"P.O. Box" & @CRLF & _
"PO. Box" & @CRLF & _
"po box" & @CRLF & _
"P.o box" & @CRLF & _
"PoBox" & @CRLF & _
"p.o. Box" & @CRLF & _
"post office box 716" & @CRLF & _
"Post O. box " & @CRLF & _
"Post off box" & @CRLF & _
"p office box" & @CRLF & _
"p off BOX" & @CRLF & _
"" & @CRLF & _
"p0 box" & @CRLF & _
"p0ffice box k"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")