import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "P(ost)?[\\.\\s]*(O|0)(ff(ice)?)?[\\.\\s]+B(o|0)x";
final String string = "PO Box\n"
+ "P.O. Box\n"
+ "PO. Box\n"
+ "po box\n"
+ "P.o box\n"
+ "PoBox\n"
+ "p.o. Box\n"
+ "post office box 716\n"
+ "Post O. box \n"
+ "Post off box\n"
+ "p office box\n"
+ "p off BOX\n\n"
+ "p0 box\n"
+ "p0ffice box k";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}