# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((?! xxxx-xx-xx)((19|20|x)[0-9x][0-9x])\-((02\-(-[1-9]|[1-2]\d|xx))|((04|06|09|11)\-(0[1-9]|[1-2]\d|30|xx))|((01|03|05|07|08|10|12|xx)\-(0[1-9]|[1-2]\d|30|31|xx)))((?! xx:xx:xx) ([0-1]\d|2[0-3]|xx):([0-5]\d|xx)(:([0-5]\d|xx)|))?)$"
test_str = ("xxxx-xx-xx\n"
"2011-12-22\n"
"2014-10-11\n"
"2014-10-17 08:11:11\n"
"2014-10-10 xx:10:xx\n"
"2014-10-21 xx:xx\n"
"2014-10-01 10:xx:xx\n"
"2014-10-03 xx:10:xx\n"
"2014-10-14 xx:xx:10\n"
"2014-10-13 10:10:xx\n"
"2014-10-15 xx:10:10\n"
"2014-10-16 10:xx:10\n"
"2014-10-17 10:11:10\n"
"xxxx-xx-xx 10:11:10\n"
"2014-10-18 xx:xx:xx\n"
"xxxx-xx-xx xx:xx:01\n"
"xxx-xx-xx xx:xx:01\n"
"xxx-xx-xx xx:xx:xx\n"
"xxxx-xx-xx xx:xx:xx")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.