import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?! xxxx-xx-xx)((19|20|x)[0-9x][0-9x])\\-((02\\-(-[1-9]|[1-2]\\d|xx))|((04|06|09|11)\\-(0[1-9]|[1-2]\\d|30|xx))|((01|03|05|07|08|10|12|xx)\\-(0[1-9]|[1-2]\\d|30|31|xx)))((?! xx:xx:xx) ([0-1]\\d|2[0-3]|xx):([0-5]\\d|xx)(:([0-5]\\d|xx)|))?)$";
final String string = "xxxx-xx-xx\n"
+ "2011-12-22\n"
+ "2014-10-11\n"
+ "2014-10-17 08:11:11\n"
+ "2014-10-10 xx:10:xx\n"
+ "2014-10-21 xx:xx\n"
+ "2014-10-01 10:xx:xx\n"
+ "2014-10-03 xx:10:xx\n"
+ "2014-10-14 xx:xx:10\n"
+ "2014-10-13 10:10:xx\n"
+ "2014-10-15 xx:10:10\n"
+ "2014-10-16 10:xx:10\n"
+ "2014-10-17 10:11:10\n"
+ "xxxx-xx-xx 10:11:10\n"
+ "2014-10-18 xx:xx:xx\n"
+ "xxxx-xx-xx xx:xx:01\n"
+ "xxx-xx-xx xx:xx:01\n"
+ "xxx-xx-xx xx:xx:xx\n"
+ "xxxx-xx-xx xx:xx:xx";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}