using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?! xxxx-xx-xx)((19|20|x)[0-9x][0-9x])\-((02\-(-[1-9]|[1-2]\d|xx))|((04|06|09|11)\-(0[1-9]|[1-2]\d|30|xx))|((01|03|05|07|08|10|12|xx)\-(0[1-9]|[1-2]\d|30|31|xx)))((?! xx:xx:xx) ([0-1]\d|2[0-3]|xx):([0-5]\d|xx)(:([0-5]\d|xx)|))?)$";
string input = @"xxxx-xx-xx
2011-12-22
2014-10-11
2014-10-17 08:11:11
2014-10-10 xx:10:xx
2014-10-21 xx:xx
2014-10-01 10:xx:xx
2014-10-03 xx:10:xx
2014-10-14 xx:xx:10
2014-10-13 10:10:xx
2014-10-15 xx:10:10
2014-10-16 10:xx:10
2014-10-17 10:11:10
xxxx-xx-xx 10:11:10
2014-10-18 xx:xx:xx
xxxx-xx-xx xx:xx:01
xxx-xx-xx xx:xx:01
xxx-xx-xx xx:xx:xx
xxxx-xx-xx xx:xx:xx";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}