#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?! xxxx-xx-xx)((19|20|x)[0-9x][0-9x])\-((02\-(-[1-9]|[1-2]\d|xx))|((04|06|09|11)\-(0[1-9]|[1-2]\d|30|xx))|((01|03|05|07|08|10|12|xx)\-(0[1-9]|[1-2]\d|30|31|xx)))((?! xx:xx:xx) ([0-1]\d|2[0-3]|xx):([0-5]\d|xx)(:([0-5]\d|xx)|))?)$"
Local $sString = "xxxx-xx-xx" & @CRLF & _
"2011-12-22" & @CRLF & _
"2014-10-11" & @CRLF & _
"2014-10-17 08:11:11" & @CRLF & _
"2014-10-10 xx:10:xx" & @CRLF & _
"2014-10-21 xx:xx" & @CRLF & _
"2014-10-01 10:xx:xx" & @CRLF & _
"2014-10-03 xx:10:xx" & @CRLF & _
"2014-10-14 xx:xx:10" & @CRLF & _
"2014-10-13 10:10:xx" & @CRLF & _
"2014-10-15 xx:10:10" & @CRLF & _
"2014-10-16 10:xx:10" & @CRLF & _
"2014-10-17 10:11:10" & @CRLF & _
"xxxx-xx-xx 10:11:10" & @CRLF & _
"2014-10-18 xx:xx:xx" & @CRLF & _
"xxxx-xx-xx xx:xx:01" & @CRLF & _
"xxx-xx-xx xx:xx:01" & @CRLF & _
"xxx-xx-xx xx:xx:xx" & @CRLF & _
"xxxx-xx-xx xx:xx:xx"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")