use strict;
my $str = 'xxxx-xx-xx
2011-12-22
2014-10-11
2014-10-17 08:11:11
2014-10-10 xx:10:xx
2014-10-21 xx:xx
2014-10-01 10:xx:xx
2014-10-03 xx:10:xx
2014-10-14 xx:xx:10
2014-10-13 10:10:xx
2014-10-15 xx:10:10
2014-10-16 10:xx:10
2014-10-17 10:11:10
xxxx-xx-xx 10:11:10
2014-10-18 xx:xx:xx
xxxx-xx-xx xx:xx:01
xxx-xx-xx xx:xx:01
xxx-xx-xx xx:xx:xx
xxxx-xx-xx xx:xx:xx';
my $regex = qr/^((?! xxxx-xx-xx)((19|20|x)[0-9x][0-9x])\-((02\-(-[1-9]|[1-2]\d|xx))|((04|06|09|11)\-(0[1-9]|[1-2]\d|30|xx))|((01|03|05|07|08|10|12|xx)\-(0[1-9]|[1-2]\d|30|31|xx)))((?! xx:xx:xx) ([0-1]\d|2[0-3]|xx):([0-5]\d|xx)(:([0-5]\d|xx)|))?)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}