# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([a-zA-Z]{0,3}\$\s*)?(([1-9]\d{0,2})(,\d{3}){0,3}(,\d{3})|(\d{1,14}))(\.\d{2})?$"
test_str = ("/* Valid */\n"
"$9\n"
"R$9.99\n"
"R$ 9.99\n"
"BRL$9.99\n"
"9\n"
"99999999999999\n"
"99999999999999.99\n"
"9,000.99\n"
"99,000.99\n"
"999,000.99\n"
"9,000,000.99\n"
"99,000,000.99\n"
"999,000,000.99\n"
"999,000,000.99\n"
"9,000,000,000.99\n"
"99,000,000,000.99\n"
"999,000,000,000.99\n"
"9,000\n"
"99,000\n"
"999,000\n"
"9,000,000\n"
"99,000,000\n"
"999,000,000\n"
"999,000,000\n"
"9,000,000,000\n"
"99,000,000,000\n"
"999,000,000,000\n"
"/* Invalid */\n"
"R9\n"
"R$9,99\n"
"999999999999999\n"
"999999999999999.99\n"
"0,000.99\n"
"09,000.99\n"
"099,000.99\n"
"0,000,000.99\n"
"09,000,000.99\n"
"099,000,000.99\n"
"099,000,000.99\n"
"0,000,000,000.99\n"
"09,000,000,000.99\n"
"099,000,000,000.99\n"
"0,999\n"
",99,000\n"
"99,9,000\n"
"99,99,000\n"
"9,9999,000\n"
"9,99,000,000\n"
",999999,000\n"
"99,99,000,000\n"
"999,999999,000\n"
"999999,000,000")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.