use strict;
my $str = '/* Valid */
$9
R$9.99
R$ 9.99
BRL$9.99
9
99999999999999
99999999999999.99
9,000.99
99,000.99
999,000.99
9,000,000.99
99,000,000.99
999,000,000.99
999,000,000.99
9,000,000,000.99
99,000,000,000.99
999,000,000,000.99
9,000
99,000
999,000
9,000,000
99,000,000
999,000,000
999,000,000
9,000,000,000
99,000,000,000
999,000,000,000
/* Invalid */
R9
R$9,99
999999999999999
999999999999999.99
0,000.99
09,000.99
099,000.99
0,000,000.99
09,000,000.99
099,000,000.99
099,000,000.99
0,000,000,000.99
09,000,000,000.99
099,000,000,000.99
0,999
,99,000
99,9,000
99,99,000
9,9999,000
9,99,000,000
,999999,000
99,99,000,000
999,999999,000
999999,000,000';
my $regex = qr/^([a-zA-Z]{0,3}\$\s*)?(([1-9]\d{0,2})(,\d{3}){0,3}(,\d{3})|(\d{1,14}))(\.\d{2})?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}