package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-zA-Z]{0,3}\$\s*)?(([1-9]\d{0,2})(,\d{3}){0,3}(,\d{3})|(\d{1,14}))(\.\d{2})?$`)
var str = `/* Valid */
$9
R$9.99
R$ 9.99
BRL$9.99
9
99999999999999
99999999999999.99
9,000.99
99,000.99
999,000.99
9,000,000.99
99,000,000.99
999,000,000.99
999,000,000.99
9,000,000,000.99
99,000,000,000.99
999,000,000,000.99
9,000
99,000
999,000
9,000,000
99,000,000
999,000,000
999,000,000
9,000,000,000
99,000,000,000
999,000,000,000
/* Invalid */
R9
R$9,99
999999999999999
999999999999999.99
0,000.99
09,000.99
099,000.99
0,000,000.99
09,000,000.99
099,000,000.99
099,000,000.99
0,000,000,000.99
09,000,000,000.99
099,000,000,000.99
0,999
,99,000
99,9,000
99,99,000
9,9999,000
9,99,000,000
,999999,000
99,99,000,000
999,999999,000
999999,000,000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}