import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-zA-Z]{0,3}\\$\\s*)?(([1-9]\\d{0,2})(,\\d{3}){0,3}(,\\d{3})|(\\d{1,14}))(\\.\\d{2})?$";
final String string = "/* Valid */\n"
+ "$9\n"
+ "R$9.99\n"
+ "R$ 9.99\n"
+ "BRL$9.99\n"
+ "9\n"
+ "99999999999999\n"
+ "99999999999999.99\n"
+ "9,000.99\n"
+ "99,000.99\n"
+ "999,000.99\n"
+ "9,000,000.99\n"
+ "99,000,000.99\n"
+ "999,000,000.99\n"
+ "999,000,000.99\n"
+ "9,000,000,000.99\n"
+ "99,000,000,000.99\n"
+ "999,000,000,000.99\n"
+ "9,000\n"
+ "99,000\n"
+ "999,000\n"
+ "9,000,000\n"
+ "99,000,000\n"
+ "999,000,000\n"
+ "999,000,000\n"
+ "9,000,000,000\n"
+ "99,000,000,000\n"
+ "999,000,000,000\n"
+ "/* Invalid */\n"
+ "R9\n"
+ "R$9,99\n"
+ "999999999999999\n"
+ "999999999999999.99\n"
+ "0,000.99\n"
+ "09,000.99\n"
+ "099,000.99\n"
+ "0,000,000.99\n"
+ "09,000,000.99\n"
+ "099,000,000.99\n"
+ "099,000,000.99\n"
+ "0,000,000,000.99\n"
+ "09,000,000,000.99\n"
+ "099,000,000,000.99\n"
+ "0,999\n"
+ ",99,000\n"
+ "99,9,000\n"
+ "99,99,000\n"
+ "9,9999,000\n"
+ "9,99,000,000\n"
+ ",999999,000\n"
+ "99,99,000,000\n"
+ "999,999999,000\n"
+ "999999,000,000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}