import Foundation
let pattern = #"(?<!\/)(\/(?=\b).+)\[(\d+), (\d+)\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"// test /Users/zachhardesty/MEGA/ibm/webui/WEB_UI_CONTENT_REACT/src/modules/IdentitySources/Components/index.ts[1, 1]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1:$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)