$re = '/(?<!\/)(\/(?=\b).+)\[(\d+), (\d+)\]/m';
$str = '// test /Users/zachhardesty/MEGA/ibm/webui/WEB_UI_CONTENT_REACT/src/modules/IdentitySources/Components/index.ts[1, 1]';
$subst = "$1:$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;