const regex = /(?<!\/)(\/(?=\b).+)\[(\d+), (\d+)\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\\/)(\\\/(?=\\b).+)\\[(\\d+), (\\d+)\\]', 'gm')
const str = `// test /Users/zachhardesty/MEGA/ibm/webui/WEB_UI_CONTENT_REACT/src/modules/IdentitySources/Components/index.ts[1, 1]`;
const subst = `$1:$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);