use strict;
my $str = '// test /Users/zachhardesty/MEGA/ibm/webui/WEB_UI_CONTENT_REACT/src/modules/IdentitySources/Components/index.ts[1, 1]';
my $regex = qr/(?<!\/)(\/(?=\b).+)\[(\d+), (\d+)\]/mp;
my $subst = '$1:$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";