#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!\/)(\/(?=\b).+)\[(\d+), (\d+)\]"
Local $sString = "// test /Users/zachhardesty/MEGA/ibm/webui/WEB_UI_CONTENT_REACT/src/modules/IdentitySources/Components/index.ts[1, 1]"
Local $sSubst = "$1:$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)