import Foundation
let pattern = #"""
('click \.buttonaudio': function\(evt\) {
(\$\.k2l\.m.{1,2}a.{1,2}_{0,1}.{0,2}\.sound)\.src = \$\(evt\.currentTarget\)\.attr\('data-audiosrc'\);)
(\$\.k2l\.m.{1,2}a.{1,2}_{0,1}.{0,2}\.sound\.play\(\);
},)
"""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
'click .buttonaudio': function(evt) {
$.k2l.m2a24_6.sound.src = $(evt.currentTarget).attr('data-audiosrc');
$.k2l.m2a24_6.sound.play();
},
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\n\t\taddSpinner(\2,$(evt.currentTarget);\n\t\t\3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)