#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "('click \.buttonaudio': function\(evt\) {" & @CRLF & _
" (\$\.k2l\.m.{1,2}a.{1,2}_{0,1}.{0,2}\.sound)\.src = \$\(evt\.currentTarget\)\.attr\('data-audiosrc'\);)" & @CRLF & _
" (\$\.k2l\.m.{1,2}a.{1,2}_{0,1}.{0,2}\.sound\.play\(\);" & @CRLF & _
" },)"
Local $sString = "'click .buttonaudio': function(evt) {" & @CRLF & _
" $.k2l.m2a24_6.sound.src = $(evt.currentTarget).attr('data-audiosrc');" & @CRLF & _
" $.k2l.m2a24_6.sound.play();" & @CRLF & _
" },"
Local $sSubst = "\1\n\t\taddSpinner(\2,$(evt.currentTarget);\n\t\t\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)