import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "('click \\.buttonaudio': function\\(evt\\) \\{\n"
+ " (\\$\\.k2l\\.m.{1,2}a.{1,2}_{0,1}.{0,2}\\.sound)\\.src = \\$\\(evt\\.currentTarget\\)\\.attr\\('data-audiosrc'\\);)\n"
+ " (\\$\\.k2l\\.m.{1,2}a.{1,2}_{0,1}.{0,2}\\.sound\\.play\\(\\);\n"
+ " \\},)";
final String string = "'click .buttonaudio': function(evt) {\n"
+ " $.k2l.m2a24_6.sound.src = $(evt.currentTarget).attr('data-audiosrc');\n"
+ " $.k2l.m2a24_6.sound.play();\n"
+ " },";
final String subst = "\\1\\n\\t\\taddSpinner(\\2,$(evt.currentTarget);\\n\\t\\t\\3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}