$re = '/(\'click \.buttonaudio\': function\(evt\) {
(\$\.k2l\.m.{1,2}a.{1,2}_{0,1}.{0,2}\.sound)\.src = \$\(evt\.currentTarget\)\.attr\(\'data-audiosrc\'\);)
(\$\.k2l\.m.{1,2}a.{1,2}_{0,1}.{0,2}\.sound\.play\(\);
},)/';
$str = '\'click .buttonaudio\': function(evt) {
$.k2l.m2a24_6.sound.src = $(evt.currentTarget).attr(\'data-audiosrc\');
$.k2l.m2a24_6.sound.play();
},';
$subst = "\1\n\t\taddSpinner(\2,$(evt.currentTarget);\n\t\t\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;