const regex = /('click \.buttonaudio': function\(evt\) {
(\$\.k2l\.m.{1,2}a.{1,2}_{0,1}.{0,2}\.sound)\.src = \$\(evt\.currentTarget\)\.attr\('data-audiosrc'\);)
(\$\.k2l\.m.{1,2}a.{1,2}_{0,1}.{0,2}\.sound\.play\(\);
},)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\'click \\.buttonaudio\': function\\(evt\\) {
(\\$\\.k2l\\.m.{1,2}a.{1,2}_{0,1}.{0,2}\\.sound)\\.src = \\$\\(evt\\.currentTarget\\)\\.attr\\(\'data-audiosrc\'\\);)
(\\$\\.k2l\\.m.{1,2}a.{1,2}_{0,1}.{0,2}\\.sound\\.play\\(\\);
},)', 'g')
const str = `'click .buttonaudio': function(evt) {
\$.k2l.m2a24_6.sound.src = \$(evt.currentTarget).attr('data-audiosrc');
\$.k2l.m2a24_6.sound.play();
},`;
const subst = `\1\n\t\taddSpinner(\2,$(evt.currentTarget);\n\t\t\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);