// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)<table[^>]*>(.*?)<\/table>").unwrap();
let string = "<table id=\"tbl\" class=\"table-fill\">
<thead>
<tr>
<th>IP</th>
<th>Port</th>
<th>Anonymity</th>
<th>Country</th>
</tr>
</thead>
<tbody id=\"tabli\" class=\"table-hover\">
<tr>
<td>84.17.51.209</td>
<td>3128</td>
<td>Transparent</td>
<td>United Kingdom</td>
</tr>
<tr>
<td>84.17.51.209</td>
<td>3128</td>
<td>Transparent</td>
<td>United Kingdom</td>
</tr>
</table>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}