import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<table[^>]*>(.*?)<\\/table>";
final String string = "<table id=\"tbl\" class=\"table-fill\">\n"
+ "<thead>\n"
+ "<tr>\n"
+ "<th>IP</th>\n"
+ "<th>Port</th>\n"
+ "<th>Anonymity</th>\n"
+ "<th>Country</th>\n"
+ "</tr>\n"
+ "</thead>\n"
+ "<tbody id=\"tabli\" class=\"table-hover\">\n"
+ "<tr>\n"
+ "<td>84.17.51.209</td>\n"
+ "<td>3128</td>\n"
+ "<td>Transparent</td>\n"
+ "<td>United Kingdom</td>\n"
+ "</tr>\n"
+ "<tr>\n"
+ "<td>84.17.51.209</td>\n"
+ "<td>3128</td>\n"
+ "<td>Transparent</td>\n"
+ "<td>United Kingdom</td>\n"
+ "</tr>\n"
+ "</table>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}