use strict;
my $str = '<table id="tbl" class="table-fill">
<thead>
<tr>
<th>IP</th>
<th>Port</th>
<th>Anonymity</th>
<th>Country</th>
</tr>
</thead>
<tbody id="tabli" class="table-hover">
<tr>
<td>84.17.51.209</td>
<td>3128</td>
<td>Transparent</td>
<td>United Kingdom</td>
</tr>
<tr>
<td>84.17.51.209</td>
<td>3128</td>
<td>Transparent</td>
<td>United Kingdom</td>
</tr>
</table>';
my $regex = qr/<table[^>]*>(.*?)<\/table>/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}