# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<table[^>]*>(.*?)<\/table>"
test_str = ("<table id=\"tbl\" class=\"table-fill\">\n"
"<thead>\n"
"<tr>\n"
"<th>IP</th>\n"
"<th>Port</th>\n"
"<th>Anonymity</th>\n"
"<th>Country</th>\n"
"</tr>\n"
"</thead>\n"
"<tbody id=\"tabli\" class=\"table-hover\">\n"
"<tr>\n"
"<td>84.17.51.209</td>\n"
"<td>3128</td>\n"
"<td>Transparent</td>\n"
"<td>United Kingdom</td>\n"
"</tr>\n"
"<tr>\n"
"<td>84.17.51.209</td>\n"
"<td>3128</td>\n"
"<td>Transparent</td>\n"
"<td>United Kingdom</td>\n"
"</tr>\n"
"</table>")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.