$re = '/<table[^>]*>(.*?)<\/table>/ms';
$str = '<table id="tbl" class="table-fill">
<thead>
<tr>
<th>IP</th>
<th>Port</th>
<th>Anonymity</th>
<th>Country</th>
</tr>
</thead>
<tbody id="tabli" class="table-hover">
<tr>
<td>84.17.51.209</td>
<td>3128</td>
<td>Transparent</td>
<td>United Kingdom</td>
</tr>
<tr>
<td>84.17.51.209</td>
<td>3128</td>
<td>Transparent</td>
<td>United Kingdom</td>
</tr>
</table>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);