// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^| |[a-z-A-Z]{2,}|[a-df-zA-Z]| *-[0-9]+|[0-9]+)(-)([0-9]+|[0-9]+e[0-9]+|[0-9]+-e[0-9]+)").unwrap();
let string = "-1
1-1
1e1
1e-1
-1e-1
1e-1-1e-1
-1e-1-1e-1
last-1
last-1e-1-1e-1
1+1 -1-1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}