using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^| |[a-z-A-Z]{2,}|[a-df-zA-Z]| *-[0-9]+|[0-9]+)(-)([0-9]+|[0-9]+e[0-9]+|[0-9]+-e[0-9]+)";
string input = @"-1
1-1
1e1
1e-1
-1e-1
1e-1-1e-1
-1e-1-1e-1
last-1
last-1e-1-1e-1
1+1 -1-1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}