import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^| |[a-z-A-Z]{2,}|[a-df-zA-Z]| *-[0-9]+|[0-9]+)(-)([0-9]+|[0-9]+e[0-9]+|[0-9]+-e[0-9]+)";
final String string = "-1\n"
+ "1-1\n"
+ "1e1\n"
+ "1e-1\n"
+ "-1e-1\n"
+ "1e-1-1e-1\n"
+ "-1e-1-1e-1\n"
+ "last-1\n"
+ "last-1e-1-1e-1\n"
+ "1+1 -1-1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}