re = /(^| |[a-z-A-Z]{2,}|[a-df-zA-Z]| *-[0-9]+|[0-9]+)(-)([0-9]+|[0-9]+e[0-9]+|[0-9]+-e[0-9]+)/m
str = '-1
1-1
1e1
1e-1
-1e-1
1e-1-1e-1
-1e-1-1e-1
last-1
last-1e-1-1e-1
1+1 -1-1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end