import Foundation
let pattern = #"([^\:\n,]+:\d+,?)+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
abc:cde,qwe:rty,tyu:asd
abc,cde,qwe:rty.tyu:asd
abcc|dexqwe-rty!tyu(asd
host1:1,23,dsaf,host2:345
host1:1,23,,host2:345,,
host1:1,23,,host2:345
host1:123,host2:345
eos-kfk1-ro-prod.emag.network:9092,eos-kfk2-ro-prod.emag.network:9092,eos-kfk3-ro-prod.emag.network:9092
10.249.34.90:9092,10.249.34.91:9092,10.249.34.92:9092
([^\\:\\n]+:\\d+[,]?)+
([^\:\n]+:\d+)+,?
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)