#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([^\:\n,]+:\d+,?)+"
Local $sString = "abc:cde,qwe:rty,tyu:asd" & @CRLF & _
"abc,cde,qwe:rty.tyu:asd" & @CRLF & _
"abcc|dexqwe-rty!tyu(asd" & @CRLF & _
"host1:1,23,dsaf,host2:345" & @CRLF & _
"host1:1,23,,host2:345,," & @CRLF & _
"host1:1,23,,host2:345" & @CRLF & _
"host1:123,host2:345" & @CRLF & _
"eos-kfk1-ro-prod.emag.network:9092,eos-kfk2-ro-prod.emag.network:9092,eos-kfk3-ro-prod.emag.network:9092" & @CRLF & _
"10.249.34.90:9092,10.249.34.91:9092,10.249.34.92:9092" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"([^\\:\\n]+:\\d+[,]?)+" & @CRLF & _
"" & @CRLF & _
"([^\:\n]+:\d+)+,?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")