import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^\\:\\n,]+:\\d+,?)+";
final String string = "abc:cde,qwe:rty,tyu:asd\n"
+ "abc,cde,qwe:rty.tyu:asd\n"
+ "abcc|dexqwe-rty!tyu(asd\n"
+ "host1:1,23,dsaf,host2:345\n"
+ "host1:1,23,,host2:345,,\n"
+ "host1:1,23,,host2:345\n"
+ "host1:123,host2:345\n"
+ "eos-kfk1-ro-prod.emag.network:9092,eos-kfk2-ro-prod.emag.network:9092,eos-kfk3-ro-prod.emag.network:9092\n"
+ "10.249.34.90:9092,10.249.34.91:9092,10.249.34.92:9092\n\n\n"
+ "([^\\\\:\\\\n]+:\\\\d+[,]?)+\n\n"
+ "([^\\:\\n]+:\\d+)+,?";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}